SM2.0: just crashes alot

Discuss suspected defects before submitting a bug report

Moderator: electrogear

SM2.0: just crashes alot

Postby infuzion on Sun Jan 02, 2011 6:00 am

SM2.0: Crashes when DS Out is turned off, happened alot in 1.1.7 when working with various OSMs. Sometimes I turn it off to just turn off the audio, sometimes to recals the audio path.
No bug report windows either.

edit: Just seems SM 2.0 crashes alot more than 1.1.7, almost to the point of frustration. Often it is with the DS Out turning off & on, but also copy/pasting, switching to another pre-loaded OSM... about once every 30 minutes, very random, with different OSMs, & always skipping SM's bug reporter, & often skipping WinXP's.
Fortunately, I can often save the current OSM if it just crashes to WinXP's reporter.
Need help? First search the forum & WiKi, then post in the help forum with a clear topic, request, & OSM. Then please WiKi the correct solution. If you want my personal assistance, I charge by the hour or for an exchange of services.
infuzion
smstar
smstar
 
Posts: 6169
Joined: Wed May 04, 2005 8:02 pm
Location: Earth, USA, CO, Denver

Re: SM2.0: just crashes alot

Postby infuzion on Tue Jan 04, 2011 6:37 pm

Common pre-crash events:
- Turning the DS Sound on or off
- copy-pasting
- closing out an OSM, usually when closing out SM

One bad crash corrupted a save :/

Reports & OSMs sent.
Need help? First search the forum & WiKi, then post in the help forum with a clear topic, request, & OSM. Then please WiKi the correct solution. If you want my personal assistance, I charge by the hour or for an exchange of services.
infuzion
smstar
smstar
 
Posts: 6169
Joined: Wed May 04, 2005 8:02 pm
Location: Earth, USA, CO, Denver

Re: SM2.0: just crashes alot

Postby MichaelBenjamin on Tue Jan 04, 2011 7:49 pm

i had some situation where editing code connected to an analyser first worked, (i could make changes, let recompile, change), then after a reload of that schematic it instantly crashed on recompile of that codebox. i could not do anything but delete that box and write again. even clicking in the codebox and not changing anything then recompile that same code made sm disappear. there was stage 0 and 1 involved. and it was box dropped code from 1.1.7.
so far for me sm2.0 saves working osms that it cant properly re-load.
also i had encountered the randomly-skip-midi note in some other osm that mvdlee reported first. (hadnt used midi poly for a while).
untill that is fixed, i think i will load up 1.1.7 again (with messed up folders).
User avatar
MichaelBenjamin
smaniac
 
Posts: 1439
Joined: Thu Jul 12, 2007 3:26 pm

Re: SM2.0: just crashes alot

Postby infuzion on Thu Jan 13, 2011 5:11 am

infuzion wrote:...Often it is with the DS Out turning off & on, but also copy/pasting, switching to another pre-loaded OSM... about once every 30 minutes, very random, with different OSMs, & always skipping SM's bug reporter, & often skipping WinXP's.
Malc confirmed that turning off & on the DS Out does very randomly, as far back to atleast 1.1.7
Hard to isolate, since it is very random.
Need help? First search the forum & WiKi, then post in the help forum with a clear topic, request, & OSM. Then please WiKi the correct solution. If you want my personal assistance, I charge by the hour or for an exchange of services.
infuzion
smstar
smstar
 
Posts: 6169
Joined: Wed May 04, 2005 8:02 pm
Location: Earth, USA, CO, Denver

Re: SM2.0: just crashes alot

Postby infuzion on Mon Jan 17, 2011 2:57 am

I tried to drag & drop an OSM into SM & it crashed. At least I got an SM crash report this time, which was emailed.
edit: another crash-often: MyCo's version viewtopic.php?f=12&t=5398
Need help? First search the forum & WiKi, then post in the help forum with a clear topic, request, & OSM. Then please WiKi the correct solution. If you want my personal assistance, I charge by the hour or for an exchange of services.
infuzion
smstar
smstar
 
Posts: 6169
Joined: Wed May 04, 2005 8:02 pm
Location: Earth, USA, CO, Denver

Re: SM2.0: just crashes alot

Postby mshilarious on Fri Jul 15, 2011 3:45 am

I had a crash tonight to a BSOD during a file/save operation that corrupted the file. Lost the night's work, unless there is some utility to recover corrupted files :( I will post the OSM if so . . .

I only seem to have trouble when the DS input is engaged, output toggling does not cause crashes for me if the input module is not connected. I am on 2.0.4, which seems to be about the same as the 1.1.7 as I can recall.
mshilarious
essemer
 
Posts: 31
Joined: Thu Aug 23, 2007 2:16 am
Location: OBX, NC

Re: SM2.0: just crashes alot

Postby infuzion on Fri Jul 15, 2011 7:26 am

mshilarious wrote:I had a crash tonight to a BSOD during a file/save operation that corrupted the file. Lost the night's work, unless there is some utility to recover corrupted files :( I will post the OSM if so . . .
Yes, you have to look in your app data folder, for me it is in: D:\Documents and Settings\t\Application Data\SynthMaker

Everyone should always save your work under a new filename every 20min at the least. I use PROJECT##workDone.osm
Need help? First search the forum & WiKi, then post in the help forum with a clear topic, request, & OSM. Then please WiKi the correct solution. If you want my personal assistance, I charge by the hour or for an exchange of services.
infuzion
smstar
smstar
 
Posts: 6169
Joined: Wed May 04, 2005 8:02 pm
Location: Earth, USA, CO, Denver

Re: SM2.0: just crashes alot

Postby tor on Fri Jul 22, 2011 9:56 am

Lately SM 2.05 often crash when i try to disconnect mono or packed streams. I also experienced that working in a unsynced module totally different from other synced modules affect the synced ones?????

I have sendt the crash reports to support.

Also I have a strange issue where a nonrecursive algorithm (tanHish) when placed at the output of my EQ creates ripples near nyquist. The EQ has a flat frequency response and so does the algorithm. But in series inside a plug I get the ripple. I really dont know if this is a issue with synthmaker or VST plugin analyzer.

Here is the VST with the ripples if you would like to have a look at it:
http://dl.dropbox.com/u/5591159/DoublePrecisionEqualizer%20v2.dll

Any ideas?
Any sufficiently advanced technology is indistinguishable from magic.
Arthur C. Clarke, "Profiles of The Future", 1961 (Clarke's third law)

http://www.audioteknikk.net
User avatar
tor
essemilian
 
Posts: 469
Joined: Wed Apr 14, 2010 8:52 pm

Re: SM2.0: just crashes alot

Postby tor on Fri Jul 22, 2011 11:32 am

Here you have the EQ without the saturation:
http://dl.dropbox.com/u/5591159/DoublePrecisionEqualizer%20v2%20no%20sat.dll
And here the saturation with a level knob on the input:
http://dl.dropbox.com/u/5591159/Saturation.dll
It just does not make sence to me...
Any sufficiently advanced technology is indistinguishable from magic.
Arthur C. Clarke, "Profiles of The Future", 1961 (Clarke's third law)

http://www.audioteknikk.net
User avatar
tor
essemilian
 
Posts: 469
Joined: Wed Apr 14, 2010 8:52 pm


Return to Bugs

Who is online

Users browsing this forum: TurnitinBot [Bot] and 0 guests